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Over ten years ago in a dimly lit basement, I started using the Flash authoring tool to create 

unpalatable, short, frame-by-frame animations - and discovered it was much easier than other tools 
Foreword


I had been using to do the same thing. It’s hard to believe what Flash has become over the years, and how many more people are out there using it to create content and share their work. One of the nice and inspiring things about Flash is that it attracts so many different users, from creative animators to hardcore programmers, and all sorts of people in-between.

I was assigned to work on testing a new type of motion tween for Flash a few years ago. Because the feature was already developed (but at the time untested), I needed to learn how everything worked from the ground up. Similar to other migrating Flash users, I have experienced and understand the learning curve between new and classic motion tweens! The new motion tweens are a different way of thinking about animation in Flash, however they do offer many advantages such as fewer “broken” tweens, attached motion paths, independent tweenable properties, tween presets, and preset eases. Some animations I’ve created in the past were faster or easier to accomplish after a bit of time spent with the new model. What about using “classic” motion tweens? Yes, there are some workflows where classic tweens are necessary and a couple cases where they’re faster to use. However, the goal is to enhance and improve new motion tweens and the Motion Editor so using them is always possible and preferred. 

You certainly don’t need to learn everything there is to know about Flash and ActionScript to master the tool – you can choose to focus your talents on design or development, or challenge yourself from time to time by crossing over between graphics and code. But now that Flash is full of features and capable of so much, the tools can seem rather daunting to learn. But if you have helpful resources at your side, like this book, learning Flash doesn’t need to be difficult. I believe the key to learning Flash is to keep it simple when you start out, take it slow, use the available resources (like books), and try to be patient. Also don’t be afraid to go online and ask for help, we’ve all been there! Learning Flash takes some time, but it is a lot of fun and very rewarding.

Flash is an incredible tool for expressing your creativity, style, and unique ideas. Whether you’re a new or existing Flash user, now is a great time to learn or use the software and get involved with the Flash community online. I hope that you use Flash with this book to get inspired, learn valuable new tricks and techniques, and create some wonderful animation. And of course, make sure to have fun with the software while you read and learn all about how to animate!

Jen deHaan

Sr. Software Quality Engineer, Flash AuthoringAdobe Systems Inc.
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viii
How to cheat, and why

The truth about cheating

The word “cheat”, in most cases, has a negative connotation. To “cheat” implies deception and trickery associated with a fraudulent act. In some ways this book will show you how you can trick your audience, not unlike a magician’s “sleight of hand” technique where you can control not only what is being seen, but how the viewer sees it. But this book will certainly not teach you how to be a fraud.

To “cheat” in Flash is to find shortcuts to help you work more efficiently and economically.  Time translates to money and if you can deliver a great looking project on time, that means you stayed within budget and everybody wins.

My philosophy

At the end of the day, if I didn’t have any fun, then it would be time to find another job. But I had to learn this lesson the hard way a few years ago while working with an animation company designing a network television series. I was designing the main characters for a show called Science Court (ABC), and there was a conflict between us and the network as to the choice of skin color for one of the characters. I liked green and the network preferred orange. I felt strongly that my color choice was the best and I admit I may have let myself become emotionally charged about the issue. One day 

I went to lunch with the animation director and we were casually talking about the color issue. It was something he said that changed my outlook on work from that day forward: “We must have pretty cool jobs when the most stressful part of our day is whether or not a character looks too much like a frog.”

I stopped dead in my tracks, instantly realizing how right he was and how silly I felt about the matter. After lunch we returned to the studio where I immediately changed the character to orange and never uttered another word about it. I even ended up liking the orange more than the green. Since then, my philosophy has always been to have fun no matter how stressful my workday gets. My job, in comparison to all other possible occupations, is the best job even on the worst of days.

Workthroughs and examples

Each workthrough in this book is designed as a double-page spread so you can prop the book up behind your keyboard or next to your monitor as a visual reference while working alongside it. Many of the workthroughs are real-world client projects I have been commissioned to design and animate. Using these projects as examples has allowed me to provide you with a downloadable zip file containing the source files for you to open and explore. Each chapter ends with an Interlude in which I talk about 

How to cheat, and why
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ix

everything from my own experiences as a designer and animator as well as some relevant and useful information based on the topic at hand.

Flash terminology

Not much has changed when it comes to terminology in Flash. Symbols have been around since the beginning and so has the behavior any symbol can have (Graphic, Movie Clip and Button). The Timeline has remained unchanged and nesting still pertains to assets and animations within symbols, one of the key strengths of Flash. If you already have a basic understanding of Flash then you will most likely be familiar with most of the terminology in this book.
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Be social. Visit facebook.com/howtocheatinflash to ask questions, get answers or post your own works of art and animation.

Follow me on  Twitter@keyframer. I’m pretty consistent when it comes to tweeting about trends and technologies as well as cool new gadgets. You can also find out where and when my next speaking engagement will be.

Download Example Files

The download icon indicates the source file for that particular example is available for you to download from www.howtocheatinflash.com/downloads. Download the ZIP file and unpackage it to your local hard drive. The unpackaged file contains all the example files found in this book and are for your learning pleasure.

Companion Website

Please visit the companion website for this book by navigating your browser to www.howtocheatinflash.com where you can keep up to date with the information regarding this book and download the example files.

Beyond the book
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I am a digital animator – a Digimator if you will. I learned how to animate using a computer. Any animation program can have a mechanical feel to it since we work by selecting options from menus much of the time. The trick I have learned is how to make a software program like Flash feel more organic, as if it were a ball of clay, starting with a basic shape and pushing and pulling it into something unique. If this book teaches anything, I hope it teaches you to think differently as to how you approach Flash. Just because the Help docs, online resources or even other books tell you how something can or should be done, don’t take that as carved in stone. Take it as carved in clay, meaning you can continue to expand upon the ways the tools are used, even beyond what you may have read elsewhere.

The first few chapters focus on some of the basics of using Flash in real-world situations. I do not explain the rudimentary features of Flash, such as how to convert objects to symbols and what the differences are between Movie Clips and Graphic symbols. That is what the Help docs are for and are simply a keystroke (F1) or a Google search away. You bought this book to learn what goes beyond the Help docs and what can only be learned through the span of several years of experience using Flash. For you, this is the true essence of “cheating” because this book condenses those years into 300+ pages.

Just in case you do get stuck on something that you simply can’t find an explanation to, I’m a pretty easy guy to find if you want to send me your questions. You can send me a tweet @keyframer or message me on Facebook:www.facebook.com/howtocheatinflash
How to use this book

1

H

H

H

H

o

o

o

o

w

w

w

w

 

t

t

t

t

o

o

o

o

 

C

C

C

h

h

h

e

e

e

a

a

a

t

t

t

 

i

i

i

n

n

n

 

F

F

F

l

l

l

a

a

a

s

s

s

h

h

h

 

C

C

C

C










[image: background image]

22

It’s back to basics for Flash CC as the least used tools and features havebeen removed completely. Most of us weren’t using them anyway, so chances are they won’t be missed.
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What’s new in CC

ADOBE FLASH PROFESSIONAL CC MAY BE PROOF THAT less is more. The least popular and lesser-used features have been stripped from the Flash authoring tool. This lighter, more streamlined version of Flash is the version that finally fits into that polka dot bikini just in time for summer.

Let’s take a look at what’s new in Flash CC and what’s been exiled to the land of misfit features.

3
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4

W

ITH EACH NEW UPDATE 

comes new expectations 

for Flash to be better, faster and 

packed with more features. Flash 

CC is an interesting release because 

in many ways it meets these 

expectations and even exceeds 

them. But in other ways Flash CC 

may come up short for some users 

due to features that have been 

removed completely. This chapter 

takes a look at how the latest 

version of Flash stacks up for the 

designer and animator.


WWhhaaat’s nnneeewww iiinnn CCCCCC

Right off the bat, you will notice something different about Adobe Flash Professional CC. It happens so quickly, there’s a chance you might miss it. Launching Flash CC takes merely seconds thanks to a complete rewrite of its code base to support the Cocoa framework on Mac OS X. My unofficial benchmark testing shows Flash CC takes about 3 seconds to fully launch. Previous versions of Flash, such as CS6, take upwards of 30 seconds or more to launch. The updated code base is not just to speed up start times but more importantly to improve the overall stability and performance of Flash to ensure longevity on OS X. 

Based on my experience running Flash CC for several months throughout the prerelease and now the shipped version, this may be the most stable version of Flash I have ever used. Flash CC has yet to crash on my system (Mavericks, the newest Mac OS X) and I have it running nearly all day, every day. I even purposely leave it running while putting my MacBook Pro into sleep mode, just to try and get Flash to crash when waking up the operating system. So far, Flash has proven stable.
Under the hood
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5

Flash Professional CC has been enhanced to support HiDPI displays including Retina Display available on the new MacBook Pro. HiDPI display facilitates a dramatic improvement in image fidelity and resolution. With Flash Professional CS6, which was not native to HiDPI display, the text was not as sharp and images did not have much detailing. The increased resolution of these displays required the Flash Professional user interface to be updated completely and ensure that 

• Publishing time improved significantly for FLA/XFL files, having a large number of AS linkages with Warnings mode enabled.

• Performance improvements for Import to Stage and Import to Library that ensure the file open dialog launches faster.

• Launch time for Flash Professional has been reduced significantly.

• Significantly reduced time for opening AS & FLA/XFL files.

• Smoother drawing experiences with the live color preview of objects. 

• Unlimited pasteboard size.

the content is displayed with appropriate levels of fidelity. With Flash Professional CC, the icons, font, drawing on stage, general content rendering, and the whole IDE itself are displayed with superior clarity and crispness. 

By default, Flash Professional CC enables HiDPI display on MAC. However, you could turn off retina display on MAC, and Flash Professional CC will accommodate this change.

Other performance improvements
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6

S

INCE ITS INCEPTION, 

Flash has sported a very 

bright interface. From the 

white of the stage to the light 

gray menus, Flash has been 

a beacon of brightness in an 

otherwise contrasting suite of 

tools. When Flash became part 

of the Adobe Creative Suite, 

the contrast suddenly became 

more apparent as applications 

such as Photoshop and After 

Effects had already converted 

to a bold, dark interface 

design. Now with a complete 

overhaul to its core code base, 

we have the choice between 

the light or the dark side of 

Flash CC.

Darker user interface

WWhhaaat’s nnneeewww iiinnn CCCCCC

1Preferences > Generaland select your color scheme using the User Interface drop-down menu.

Your choice of interface schemes is simply dark or light. Go to 
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7

2off Shading. With Shading on, some of the menu headers and various other details will have a subtle amount of added depth. With Shading turned off, the effect is substituted for a flat shade of dark gray which provides a cleaner look and slightly faster redrawing of the panels when opened or moved across the screen.

If you choose the dark interface, you have the option to turn 

HOT TIP

You can customize the interface further in terms of how objects react when highlighted. 

In the same section of the Preferences panel you can select custom colors for Drawing Objects, Primitives, Groups, Symbols and Other Elements.
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8

L

IFE IS FULL OF LIMITATIONS. 

Lots of them. Almost 

everything around us is 

restricted to some degree of 

certainty. From warranties to 

natural resources, a run on 

stamps, clothing, automobiles 

and television shows, limitations 

are a fact of life we’re forced 

to accept. It’s difficult to find 

anything that is truly unlimited. 

Until now.


For the first time ever, Flash CC has an unlimited pasteboard 

(the area beyond the stage). 

If you are new to Flash and 

CC is the first version you’ve ever used, this new feature may not seem like a big deal. But for those of us who have used previous versions of Flash, we were all too familiar with a pasteboard limitation of no greater than 2,880 pixels. We were forced to design and animate within the confines of a limited environment. Flash was The Truman Show of the software world. As of Flash CC the confines of the pasteboard have been lifted, and all is right in the world.
Unlimited pasteboard size

WWhhaaat’s nnneeewww iiinnn CCCCCC
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9

How to Cheat in Flash CC

HOT TIP

To view the area outside of the stage known as the pasteboard, go to View > Pasteboard. 

To limit the viewable area to just the stage, repeat the same menu selection.  Magnify the stage to a value below 

100% (circled)to increase the viewable area. 

As you position objects further outside of the stage, Flash will automatically increase the pasteboard  area to accomodate their size.
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10

1ball bouncing from left to right across the stage.

In frame 1 of a new document I created a simple ball graphic using the Oval  tool and a radial gradient for depth. The plan is to animate this 

4all ,then right-click over any of the selected objects on the stage and select Distribute to Keyframes from the context menu.4

With the entire range of motion complete, the hard part is done. Select Withthtifti

S

OMETIMES CERTAIN FEATURES COME 

along that allow you to take advantage 

of them in ways they may not have been 

originally designed. It took some thinking 

on my part to come up with an example to 

showcase the new Distribute to Keyframes 

feature. Once the idea came to me, I quickly 

realized how much of a game changer this 

feature could be for anyone using Flash for 

frame-by-frame animation. Typically, frame-

by-frame animation requires an image or a 

series of images to be drawn or positioned 

across individual subsequent keyframes, a 

technique that requires frequent testing to 

make sure the timing is right. With Distribute 

to Keyframes, you can create all of your 


“animation” on a single keyframe with the convenience of seeing the spatial relationship of the object throughout each pose or, in this example, each position. 

Distribute symbols& bitmaps to keyframes
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11

2 tool. To simulate gravity the ball must increase speed as it descends, otherwise known as an easing in effect. The distance between each ball gradually increases as the ball arcs downward.

Hold down the Option  key and then click and drag the symbol to duplicate it. Position it using the Selection 

3Here the duplicate ball symbols are positioned in an acsending arc with the space between each of them decreasing to simulate an easing out movement. The advantage to animating this way is seeing the entire range of motion of the object, which provides a overall sense of timing based on the intended action. 

5keyframe. Play the timeline to see the animation of the ball bouncing. The timing will be dictated by a combination of the document frame rate as well as the relative placement of each object. Creating animation using the Distribute to 

Flash CC will distribute each selected object to its own 

HOT TIP

Distribute to Keyframes will work with objects other than symbols. You can distribute grouped objects, Object Drawings and imported bitmaps. Distribute to Keyframes will even work with multiple objects of various formats. Select any combination of bitmaps, symbols, grouped objects and Object Drawings and you can still distribute them all to keyframes with a single command.
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Keyframes method has become a part of my workflow whenever possible. In situations such as the ball bouncing example, it can be a real time saver to create your animation as a single image first, and then let Flash do the hard part by distributing everything to keyframes.
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12

1and the task at hand is to swap each one with a different symbol so that they are all instancesof the same balloon symbol. Previous versions of Flash dictated that we repeat the swap for each individual symbol which is no longer the case in Flash CC.

There is nothing complicated about this example, but more often than not we find ourselves needing to perform repetitive, mundane tasks. Each balloon is a separate symbol, 

O

FTEN IT IS THE SIMPLEST OF 

features that can make the 

biggest differences. Whenever we get 

the chance to automate repetitive 

tasks, our productivity increases 

and workflows get easier. Swapping 

symbols has been a Flash workflow 

feature for as long as Flash has been 

around. Up until Flash CC, however, 

we have only been able to swap one

symbol at a time. If you’ve ever had 

to endure the process of manually 

swapping a large number of symbols, 

then I’m happy to tell you those days 

are now over.


Swap multiple symbolsand bitmaps

4

In the Swap Symbol panel select the symbol to replace the selected symbols on the stage and then click OK.
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2Select all symbols you want to swap for a different symbol. Hold down the  key to select multiple symbols.

3The replacement symbol already resides in the library represented by the purple balloon. In the Properties panel click the Swap button.

HOT TIP

You cannot swap a symbol for a bitmap or a bitmap for a symbol. You can only swap symbols for symbols or bitmaps for bitmaps. Of course if your bitmap has been converted to a symbol, then you can convert it to a different symbol.
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5now been swapped to a the newly selected symbol. We have never been able to achieve swapping of multiple symbols in previous versions of Flash, as simple as it may be.

Each of the selected symbols on the stage have 
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1on each layer in the Timeline panel. If you want to select all layers, hold down the Shift  key, select the first layer and then the last layer. All the layers in between will also be selected.

Select multiple layers by holding down the Control  key and clicking 

3 In addition to layer types, a new outline color can be applied by clicking on the color swatch and selecting a new color from the popup palette. The new color will be assigned to all selected layers.

M

ULTIPLE LAYER SELECTION: YOU 

can now select and assign/modify 

properties to multiple layers using the 

Layer 

Properties

 dialog. Convert layers to Guides 

or Masks with the Toggle Guides and Toggle 

Masks options. In addition to Guides and 

Masks, other layer properties include:


Lock Others

Hide Others

Expand Folders

Collapse Folders

From within the Layer Properties panel you can change the layer color and height across multiple selected layers.
Toggle guides and masks

WWhhaaat’s nnneeewww iiinnn CCCCCC
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2to bring up the context menu. The options available to you in Flash CC are Lock and Hide Others, Insert and Delete layers, Cut, Copy, 

Right-click over any of the selected layers 

Duplicate layers and convert all selected layers to Guide or Mask layers. You can also select Properties to access the Layer Properties panel. From here you can toggle layer visibility, lock or unlock and select the layer type.

4Click the Layer Height drop-down menu to select a new layer height. You can choose between 100%, 200% and 300% layer heights. Click OK, and all selected layers will adopt your new settings.

HOT TIP

If you convert a layer property from Normal to Folder and then back to Normal again, you will need to insert at least 1 frame before drawing or placing objects on the stage. Press the F5 (Insert Frames) key to insert at least 

1 frame in the converted layer to allow objects to be added to your scene as intended.i
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C

HANGING THE STAGE 

size in Flash has 

been limited to the right 

and bottom sides of the 

stage in previous versions. 

The composition of your 

design was ignored during 

this process as well. If you 

have ever wanted to scale 

the stage along with the 

contents of your Flash 

document, you would have 

to do so manually, which 

can get complicated if your 

document contains long 

animations. In Flash CC we 

can now scale the stage size 

and its content together 

based on any one of nine

anchor points.


3contents, click to select either the width or height text fields of the stage size. Type in a new value for both the width and height. In this example I have chosen a new stage size of 1136 x 640 to support the iPhone 5 screen resolution. The Scale checkbox will become active, allowing you to select it, by clicking in the box to allow the content 

To enable the scaling of the document 

11024 x 768 pixels. This example will show you how to scale the stage size along with the entire contents of the timeline. Even if your Flash document contains long timeline animations, everything will be scaled according to the stage size and anchor point. Scaling the stage is very 

The Flash document has its stage size set to 

WWhhaaat’s nnneeewww iiinnn CCCCCC
Scale to Anchor point

useful if you have a project that you want to publish to various devices or mediums that have varying aspect ratios. Imagine being able to author content for output to video to be uploaded to YouTube or Vimeo but then scale that same content for an iPhone or Android smartphone or tablet.

to scale. You can also choose to scale locked and hidden layers as an option. The Anchor feature allows you to select how the content is positioned. Click on any one of the 9 squares to determine the placement of your content. For this example I selected the middle square so that all my content is centered based on the new width and height. Click the OK button.
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How to Cheat in Flash CC

2or . You will find several options within the Document Settings panel that include stage size, scale, anchor, stage color and frame rate.

Open the Document Settings panel by going to Modify > Document

4the Document Settings panel and scale the entire content of the timeline based on the selected anchor point. Pictured to the right is the new size 1136 x 640 that publishes perfectly for the iPhone 5 screen resolution.

Flash will change the stage width and height as specified in 
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D

RAGONBONES IS AN OPEN SOURCE 

2D skeleton animation program 

that contains a Flash Professional design 

panel and an AS3-based library. The design 

panel converts Flash vector animation to 

a texture atlas (also known as a Sprite 


Sheet). DragonBones integrates well with the Starling Framework, which takes advantage of GPU accelerated animation. The DragonBones extension is both designer and developer friendly. Animations can be handled entirely by the designer who can then export the necessary data to be handed off to a developer for game integration. To learn more and download the DragonBones extension, visithttp://dragonbones.github.io.

For more information on the Starling Framework, visithttp://gamua.com/starling.

1http://dragonbones.github.io. Once downloaded, double-click the XMPextension file to launch the Adobe Extension Manager CC to install 

Download the extension from

DragonBones
DragonBones extension

DragonBones for Flash CC. If Flash CC is already running, you will need to restart the application. With Flash CC running, launch the DragonBones extension by going to Window > Extensions > DragonBonesDesignPanel.

WWhhaaat’s nnneeewww iiinnn CCCCCC

4be animated. Create Blank Keyframes (F7) on every other frame and add the following frame labels: idle, walk, run, crouch and jump. The DragonBones extension will reference these frame labels once the Movie Clip has been imported later in this example.

Add a new layer to the Movie Clip timeline containing the character to 
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3Edit the Movie Clip symbol, select all the symbols of the character, right-click over them and select Distribute to Layers from the context menu.

The entire character is converted to a Movie Clip symbol. 

HOT TIP

DragonBones will only work with the same set of symbols across the entire timeline. Keep your characters simple because you will not have the luxury of swapping symbols throughout the animations. 

If you do, the DragonBones workflow will break and cause errors.
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2are setup in traditional Flash fashion. Objects are converted to symbols and organized in cut-out animation style. The ninja pictured above is comprised of 8 different symbols, each in their own layer and within a Movie Clip symbol.

The DragonBones extension uses characters that 

5state as DragonBones will do all the interpolation. For the idle animation I just want to create the ninja standing still, yet with a subtle motion as if he’s breathing a little heavy. Insert Keyframes (F6) in frame 2.

The animator needs only to create 2 poses per animation 

6slightly different position. It’s hard to notice but the head has been moved down a few pixels, the arms rotated inward slightly, the body also repositioned as well as the sword and legs.

In frame 2 each symbol of the ninja character is in a 

Continued...
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1DragonBonesDesignPanel. To begin working with DragonBones you must import the Movie Clip symbol containing the character poses and frame labels. Make sure the Library panel is open and 1

Launch the DragonBones panel by going to Window > Extensions > 
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4slider, up or down arrows or selecting the numeric value and typing in the desired duration manually. The longer the duration, the slower the animation will be. Blending Times is the number oftween frames needed to switch from one motion to another.If you enter a blending time value of 5, then 5 tweened frames will be used to transition from one motion to the currently selected motion.

Adjust the total length of the animation by using the 

5Tree window and adjust their behaviors individually using the sliders to the right. The Total Frames Scale slider controls the number of frames of the selected bone relative to the total frames of motion. The Play Delay slider controls the delay of the current bone relative to the motion it belongs to. What the 2 sliders can do is provide a secondary motion to your animations which adds a level of realism.

You can select each bone independently in the Bone 



the Movie Clip is selected. In the DragonBones panel click the Import button. In the Importpopup panel, select Selected Items from the Import drop-down menu.
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3animation as well as some easing. To access the behavior controls, click on the double arrow to expand the window. You will find Total and Blending time controls as well as Keyframe Easing and a Loop option.

You will likely want to adjust the timing of the 

HOT TIP

I highly recommend experimenting with the slider controls for each bone. With practice you will be able to achieve some realistic motions  adjusting the Total Frames Scale and Play Delay values.
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2display its contents in the preview panel on the left, the frame label data in the Behavior List panel on the right and the Bone Tree hierarchy just below that. You will notice that DragonBones has applied motion to the poses in the selected frame label using a tweening engine.

DragonBones will import the selected Movie Clip and 

6When you are finished adjusting each behavior, it is time to export the animations by clicking the Export button. In the Export drop-down menu, choose from several export options based on your needs. Here I have selected Zip (XML and PNG) format. In Export Scale dropdown box, you can set the scale of the exported texture atlas to export assets with different dimensions for devices with different resolutions. The PNG file is the atlas (or Sprite sheet) generated by DragonBones and contains all the character assets. The texture.xml file contains the atlas sheet data while the skeletal.xml file contains the animation data file. If you are purely a designer/animator, your work here is done. You can safely pass the exported XML and PNG files off to the developer who will incorporate them into the game engine.

skeleton.xmltexture.xml
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1Create a new AIR for Android or AIR for iOS document by going to File > New.... For this example I selected AIR for Android. I have 2 devices connected to my computer via USB: a Galaxy Tab and a Galaxy S4.

4going to Debug > Debug Movie > On Device via USB and selecting the connected device from the list. If you don’t see your device listed, select Refresh Device List.

You can debug your application from within the Flash CC document by 

F

multiple devices simultaneously 

via USB functionality. You can 

conveniently select from a list of 

devices of varying screen sizes, OS 

versions, and hardware configurations 

directly from your Flash CC application. 

The advantages here are being able to 

see how your application looks and 

performs across a range of platforms 

before submitting to an official store.


LASH CC NOW SUPPORTS the testing of applications on 
Multi-device connectivity

WWhhaaat’s nnneeewww iiinnn CCCCCC
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How to Cheat in Flash CC

HOT TIP

If you are having problems with your device not being recognized, make sure USB debugging mode is turned on. You can access this option by going to the system settings for your device and locating the developer tools category. On my Android devices USB Debugging is found under Settings > Developer Options > USB Debugging.

2In the Properties panel click on the wrench icon to the right of the Target drop-down menu to open the AIR for Android settings.

5To test the application on a connected device(s), go to File > Publish. The application will be installed and will automatically launch.

3you will see the connected devices in the After publishing section at the bottom. If you don’t see a device listed, click on the Refresh button.

In the AIR for Android settings panel 
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T

needed a reliable way to export our 

content directly from Flash to video 

format. In the past, we’ve experienced 

dropped frames or unexpected 

quality issues when exporting our 

animations due to an error-prone 

process that demanded large amounts 

of memory. The enhancements to the 

video exporter are the direct result of 

integrating the Adobe Media Encoder in 

Flash CC. This integration simplifies the 

video export workflow while providing 

many more encoding options for output 

to a variety of mediums.


 HIS IMPROVEMENT MAY BE THE most excitingfor animators! We’ve 

1stage size is 1920 x 1080 at 24 frames per second.

The Flash document above contains a timeline based animation using nested Graphic symbols. The entire timeline is about 15 seconds in duration. The 

4Using the AME, you can select from a variety of presets in the Preset Browser on the right side. I want to upload my animation to YouTube, so I have selected the H.264 format, specifically the YouTube HD 1080p 29.97 preset in the Preset Browser. When you are ready to export, click the green arrow near the top of the AME to begin the encoding process.

Once the video has been exported, the Adobe Media Encoder will launch automatically. The MOV file from Flash will be added to the Queue panel. 
Exporting Video

WWhhaaat’s nnneeewww iiinnn CCCCCC
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HOT TIP

The AME includes many presets for encoding your video to broadcast, mobile devices, DVD, Blu-ray, image sequence and web video. You can even create and save your own custom presets.

2

To begin the video export process go to File > Export Video... 
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3 is checked. Since my document contains timeline animation, I have selected When last frame is reached as the stopping point of the export process. Click Browse to select the path where to save your video file and then click the Export button. The Recording Flash Content progress bar will display the export process.

In the Export Video settings panel, make sure Adobe Media Encoder

Convert video in thECtidi

5With the encoding process complete, the video file can be opened and played in the Quicktime Player to verify the quality of the video is acceptable. In my experience with the new video exporter in Flash CC, each frame is flawless – even at 1920 x 1080 and with no dropped frames. 
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I

F ONLY LIFE HAD A FIND AND 

replace panel. I could imagine 

a world where if something needed 

to be fixed, it could be located and 

remedied with the help of a few input 

fields and a checkbox or 2. My to-do 

list would take minutes instead of 

hours or even days. Find and Replace 

is not new to Flash, but for the first 

time, Flash CC introduces a few subtle 

updates to the panel.


I’ve always considered the Find and Replace panel to be the unsung hero of Flash. Surprisingly, very few Flash users even know it exists, probably because it’s relatively hidden under the Edit menu as opposed to under the Window menu where most of the other panels reside. Once you’ve been introduced to this wonderful time-saving gem, you will find countless ways to use it.

1

The Find and Replace panel can be found under the Edit menu or by pressing 

 on your keyboard. 
Find & Replace enhancements

4entering specific text in the Find input field, and replace it with text entered in the Replace field.

You can refine your search by 

5Current Document from the Context drop-down menu, then click Replace or Replace All if there’s more than 1 instance that needs changing.

In the Options category, select 

WWhhaaat’s nnneeewww iiinnn CCCCCC
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dogdog



[image: p26-image_0052]

[image: p26-image_0053]

[image: p26-image_0054]




[image: background image]

27

HOT TIP

If you need to replace assets across multiple documents, make sure they are all open, and then select All Opened Files from the Context drop-down menu in the Context category. 

The Find and Replace dialog is also integrated into the Actions panel.

2The main improvement of this panel is the organization of its features into categories. Each category can be expanded or collapsed based on the content you wish to edit.

3

Using the Search drop-down menu, select from Code, Text, Font, Color, Symbol, Sound, Video or Bitmap.
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6from orange to blue. I’ve chosen Color from the Search drop-down menu and selected the original color in the Find swatch. In the Replace swatch I have chosen the new color to replace the original color and then clicked the Replace All button.

Here I am changing the color of the character across several different symbols 
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WWhhaaat’s nnneeewww iiinnn CCCCCC
Live preview for drawing tools

I

this enhancement will be 

significant for you. In Flash 

CS6, when drawing on the 

stage, you only saw the 

outlines of shapes. In Flash CC 

this is no longer the case. You 

can now preview a shape when 

using the Line, Rectangle and 

Oval tools instantaneously. The 

Live Preview feature displays 

the stroke and fill color for the 

shape along with the outline in 

real time as you are drawing.


F YOU USE THE SHAPE tools often in Flash, 

In Flash CS6, the circle shape displays the outline while actively being drawn with the Oval tool. 

In Flash CC, shapes are filled with color as they are being drawn in real time as shown above using the Rectangle tool.

The circle is filled with color only after the cursor has been released.

The circle preview includes the selected fill color  

Live Preview also includes strokes (if selected) for shapes as well as strokes made with the Line tool.
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