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CHAPTER 1[image: image]

[image: image]

Pipeline and Modeling Guidelines

The pipeline is the path that assets travel to make it into movie or game. It is important to have a solid, working pipeline in place before beginning production. Who is the first person to touch a model once the concept art is done? Where does a character go after it has been modeled? What happens if a model needs to go back for revisions? These are all question that should be answered before any art is created.

Yes, it does add some extra work before you can get to the fun part of creation, but it will save countless hours during actual production. While this book will be focusing on modeling, be aware that a pipeline encompasses all aspects of a production. At any given time, you should be able to locate art assets. Thus it is very important to become familiar with how production pipelines work.
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FIGURE 1-1   A typical production pipeline.

Concept art is the 2D designs created during pre-production. These will consist of orthographic views, reference views, and character sheets. A character sheet typically portrays the character in a variety of poses.

From concept, the pipeline usually branches out for storyboards on the animation side and maquettes on the modeling side.

Storyboards are somewhat related to animation. They are the story sequences as realized visually. The artist will compose the camera and place the characters on paper or 4 × 6 cards. If something doesn’t look right at this stage, say a camera is too tight on a character or a character’s pose is awkward, simply have the storyboard artist draw the frame again. It’s much cheaper to work out the scene staging during the storyboarding phase than it would be during production.

After the storyboards are approved, they are given to the layout department to be made into animatics. Think of an animatic as a moving storyboard. During layout, the timing and spacing of the characters will be animated as well as the camera animation. The characters are generally low polygon placeholders. Simple quick renderings or playblasts are fine. The goal is to fine tune the timing and spacing for the characters and to get the camera animation in place. Working with simple placeholder objects allows for quick reviews and redos at this stage. This amounts to a huge cost-savings benefit.

The other branch from concept art is the maquette phase. A maquette is usually a clay model built for reference purposes. The more complex the character the more likely there will be a maquette made. By allowing 3D modelers to handle a tiny statue that can be viewed from any angle, maquettes generally help for the creation of more lifelike characters. Some game companies, and almost every movie house, will have a maquette artist create a model. The 3D modeler may create the maquettes or at some larger companies there might be fulltime maquette artists on staff.

Modeling is the creation of the object or environment mesh in 3D. As with all of the other stages, the type of work may be split into smaller subgroups. For example, one person may model props, another may model Hero (a.k.a. main) characters, and still another might work on just the environments. Whatever needs to be modeled, though, it is done during this stage.
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FIGURE 1-2   Maquette.

The focus of this book, of course, is character modeling, but it is important to see how modeling fits into the pipeline. Typically multiple people will work on the same model in different capacities and that work is often done concurrently.

After modeling, an object can be textured and rigged concurrently.

During the texturing phase, a model needs to have the UV texture coordinate laid out. UVs are used to conform and hold the textures to an object. Maya creates UVs automatically, but these will almost always need to be changed. At many game companies the modeler lays out the UVs, while at a larger film company, there might be a dedicated person working on the UVs. Proper UVs are vital for a model to look correct once textured, but be forewarned, UV editing can be a very time-consuming process.

Once the UVs are complete, the textures can be created. The UVs can then be brought into an image editing program like Adobe Photoshop to be used as a template when creating the textures.

Rigging is the process of preparing a model for animation. There are many steps within the rigging phase. First a skeleton comprised of joints and bones needs to be created. A skeleton in 3D functions the same as a skeleton in the real world; it acts as the framework for the body. In 3D the body being the mesh is created by the modeler. The mesh needs to be bound and weighted to the joints so that the mesh will move with the skeleton.

After the rigging is complete, any blendshapes needed are created. Blendshapes (also known as morph targets) can be used for facial animation or for correcting problematic mesh deformations. To help keep the art consistent, blendshapes are usually created by the same person that modeled the character.
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FIGURE 1-3   A rigged character

Look development can begin at this time. Creating shading networks and designing lighting for the characters are all part of developing the look of a character.

The next step is to animate the character. Once animation is complete, fur, hair, and cloth simulations can be performed. From there, the assets move to the effects artists.

Once the animation is complete, final lighting is applied.

Finally, the character is exported into the game engine or sent to the render farm for final rendering. For film and video game cutscenes, there is an added step after rendering. All of the elements need to be composited together.

This is an example of a very simple pipeline. On large productions, each of these jobs could be further broken down into separate tasks. However, even on large productions, the goal is to make the process of getting assets into the game or movie as pain-free as possible. Often times, a model will need to go through the pipeline multiple times (if something needs to be changed, for instance) and having a smooth process to facilitate this is vital.

Now that we can see how important it is to work within a pipeline, how can that be transferred over to Maya? Maya has very simple, yet complete project tools to help set up and manage your own pipeline. In Maya these are called projects.

To set up a new project go to:

1. File>Project>New.

2. In the Project Setting window, type a name for the project and set a path.

3. Next click Use Defaults. It’s advised to always select Use Defaults as this will allow Maya to organize all of the assets for the project.

4. Click Accept.

You now have a new project and are ready to work.
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FIGURE 1-4   New project.
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FIGURE 1-5   Project settings.

For a long while, polygons were relegated mainly to video game work. For that use they excelled. The higher number of polygons needed to achieve photorealism proved to be prohibitive for film work. Thus NURBS were used extensively at many film houses.
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FIGURE 1-6   Polygon sphere on left. NURBS sphere on right.

Notice that the polygonal sphere has blocky edges. In years past, the amount of extra polygons needed to render polygon objects with smooth edges similar to those of a NURBS object would have taken too many polygons to be feasible and useable on high-resolution film projects. The render times would have been too high. The nature of NURBS surfaces allowed for very organic characters that would fit within the rendering budgets. With NURBS, though, came the extra difficulty needed in working with the surfaces. Surface patches could lose their stitching during rigging and animation. Surfaces also had to be properly parametized for texturing, and surface trims had to be dealt with if holes were needed in the model. Polygons, on the other hand, had none of these drawbacks. Their one disadvantage was the incredibly high number of polygons needed for organic characters. Polygons could be made of a single mesh. UVs could be edited independently of the model. And polygons could contain holes in the mesh as desired. Not only that, but polygons were usually much easier for new artists to learn how to use for modeling.

That has all changed now. Within the last few years, more powerful computers allow for the incredibly high amount of polygons needed for photorealistic film projects. This was a huge turning point for polygonal modelers. Now they could apply their work on film projects as well as video games.

That being said, keep in mind that there are still plenty of times where other modeling approaches will be useful. While NURBS have fallen out of favor for character modeling at most companies, they are still very useful for hard surface modeling. Vehicles are a perfect example of the type of hard surface model that many artists create using NURBS. The panel type construction of most vehicles lends itself very well to object creation using NURBS curves and surfaces. Also, because the models are hard surfaces and won’t deform, there is no danger of gaps appearing where the different surfaces meet. If you need a vase, simply create a curve outline and revolve it. Eyeballs are another good use of NURBS; the surfaces are ready to accept textures, no UV editing required.
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FIGURE 1-7   A simple vase.
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FIGURE 1-8   Polygon sphere on left and subdivision sphere on right.

Maya also comes with Subdivision Surfaces. If a production pipeline includes displacement maps, then most likely subD surfaces will be included in the mix. SubD surfaces generally produce better results than polygons when using displacement maps. When working with displacement maps, most artists will generally create the model with polygons because of the ease of working with them and then convert the model to subD surfaces prior to rendering. Not to worry, we’ll cover subD surfaces in depth later in the book.
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Overview of Maya

Maya is at the forefront of 3D graphics. The newest version of Maya has a host of new features and improvements to help the modeler achieve amazing results.

Before we move into modeling let’s go over some guideline we want to stick with to ensure clean models. These are concepts to follow when dealing with all models, be it a low polygon monster or a photorealistic human.

•   Use quad polygons: A quad is a four sided polygon. Quad polygons are generally easier for everyone to work with. Quads subdivide in a predictable manner. It is easier for a character rigger to paint weights on quads. It is also easier for the texture artist to paint images with minimal stretching. If you need to terminate an edge loop, hide the triangle in a part of the mesh that is in an inconspicuous place that won’t deform. Any triangle used needs to be kept to an absolute minimum. Polygons with more than four sides (n-gons) cannot be used.

•   Uniformly spaced topology: By uniformly spacing the polygons you will be making everyone’s job easier. Uniformly spaced models will subdivide in a predictable manner. Uniform topology has less texture stretching then unevenly spaced mesh so it is easier for the texture artists to create images. It’s also easier for the character rigger to set up the model because the weights are much easier to distribute evenly across the model.

•   Model your edge loops according to the muscles: An edge loop is a path of connected polygons. By having the edge loops follow the muscles, the character will deform much better when animated. Proper edge loops also allow you to add extra detail only in sections of the model where needed.

While this book is intended for users with experience using Maya, it should be noted that in this chapter I cover information that is important in setting up a proper workflow. Some of this may be old news for the more seasoned users. If it is, feel free to jump ahead to the information on the new tools available in Maya later in this chapter.

The Window menu is where you set the Maya scene preferences. It’s very important that before you begin working on your model you have all of your preferences set correctly.

1. Go to Window>Settings/Preferences>Preferences to bring up the Preferences window.

2. Click on Settings and set the World Coordinate System to Up Axis Y. Leave the other Settings options at their default. Maya uses centimeters for its internal measurements so working in centimeters makes sense. Most people write scripts based on the default settings of Maya. It usually won’t be an issue, but better to be safe. If you need to convert to inches, simply divide the number of centimeters by 2.5 to get the total in inches. Most production houses use Y up world coordinates so you’ll be making things much easier for yourself by setting your axis correctly to begin with.
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FIGURE 2-1   Settings/Preferences.
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FIGURE 2-2   The default Preferences window.

3. Click on Cameras. I always uncheck Fit View and Fit View All under the Animated Camera Transitions section. Some people like this feature. Personally, I don’t care for animated transitions. When I am cruising along modeling, the last I want to do is wait for the animated camera to finish its thing.
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FIGURE 2-3   Camera preferences.

4. Click on Selection. In the Polygon Selection section, select Whole Face. The default polygon face selection is Center, which is fine most of the time. But occasionally on very small faces, the center selection box is very difficult to click. By changing to whole face selection this won’t be a problem.
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FIGURE 2-4   Selection preferences.
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FIGURE 2-5   Polygon center selection (left) versus whole face selection.

Next uncheck Interactive Creation under the Create> Polygon Primitives window. Interactive Creation allows you to create a model anywhere you desire by clicking on the screen and dragging with your left mouse button. For creating a character, though, you need to have the model centered on the YZ axis. You also need to make sure Keep Faces Together is checked. This option keeps adjacent polygons that are extruded at same time welded together. To enable click Edit Mesh>Keep Faces Together.

If Keep Faces Together is off it will insert a new face between adjacent polygons during each extrude operation. Generally this is undesirable with character creation.
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FIGURE 2-6   Keep Faces Together.
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FIGURE 2-7   A cube with Keep Faces Together turned off.
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FIGURE 2-8   The same cube with Keep Faces Together turned on.

Now that all of the preferences are set, let’s look at the polygon modeling tools of choice and the new tools available in Maya.

You’ll note that Maya has a revamped interface. Chief for us is that all of the polygon tools have been moved to a new Polygons menu set. The Polygons menu is set up with more logic now. All of the tools are now very easy to find. This should help speed up productivity.
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FIGURE 2-9   Polygon menu set.


The Toolbox has a new permanent addition: the Paint Selection Tool (Edit>Paint Selection). This tool allows you to pick components by painting your selection. This can save a huge time over manual section using the marquee tools.

When used in conjunction with Quick Select Sets, you only have to select complex component groups once.

1. Right mouse click on an object and select the desired component (vertex, face, or edge) type.

2. Click the Paint Selection icon in the toolbox.

3. Paint the desired selection. This can be vertices for manipulation, faces for texturing, etc. The paint selection tool will only paint the visible side of the mesh.
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FIGURE 2-10   The Toolbox.
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FIGURE 2-11   Complex selection.


4. With the components still selected, click Create>Sets>Quick Select Set. Keep in mind that quick select sets work with more than just components. They work with most nodes in Maya. This can really help organize your scenes.
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FIGURE 2-12   Creating a quick select set.

5. At the prompt type in a name for the quick select set.
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FIGURE 2-13   The quick select prompt.

6. Anytime you need to select the set, go to Edit>Quick Select Sets and select the desired set.
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FIGURE 2-14   Using quick select sets.


Still in the toolbox is the updated Soft Modification Tool. The soft mod tool is an incredibly powerful tool for modeling. The soft mod tool now displays a color image of the falloff amount. No more guesswork. The brighter colors have a stronger deformation than the darker areas.
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FIGURE 2-15   Soft modification tool.

Click on the tool manipulator to switch to edit mode.
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