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WHERE ARE THE LESSON FILES?
Purchase of this Classroom in a Book in any format gives you access to the lesson 
files you’ll need to complete the exercises in the book. 

You’ll find the files you need on your Account page at www.peachpit.com on the 
Registered Products tab.

1 Go to www.peachpit.com/register.

2 Sign in or create a new account.

3 Enter the ISBN: 9780135298640

4 Answer the questions as proof of purchase.

5 �e lesson files can be accessed through the Registered Products tab on your 
Account page.

6  Click the Access Bonus Content link below the title of your product to  
proceed to the download page. Click the lesson file links to download them  
to your computer.

http://www.peachpit.com
http://www.peachpit.com/register
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Adobe After Effects CC provides a comprehensive set of 2D and 3D tools  
for compositing, animation, and effects that motion graphics professionals, 
visual effects artists, web designers, and film and video professionals need.  
After Effects is widely used for digital post-production of film, video, DVDs,  
and the web. You can composite layers in various ways, apply and combine 
sophisticated visual and audio effects, and animate both objects and effects.

About Classroom in a Book
Adobe After Effects CC Classroom in a Book (2019 Release) is part of the official 
training series for Adobe graphics and publishing software, developed with the 
support of Adobe product experts. �e lessons are designed to let you learn  
at your own pace. If you’re new to Adobe After Effects, you’ll learn the funda-
mental concepts and features you’ll need to master the program. And if you’ve 
been using Adobe After Effects for a while, you’ll find that Classroom in a Book 
teaches many advanced features, including tips and techniques for using the 
latest version.

Although each lesson provides step-by-step instructions for creating a specific 
project, there’s room for exploration and experimentation. You can follow  
the book from start to finish, or do only the lessons that match your interests 
and needs. Each lesson concludes with a review section summarizing what 
you’ve covered.

GETTING STARTED
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Prerequisites
Before beginning to use Adobe After Effects CC Classroom in a Book (2019 
Release), make sure that your system is set up correctly and that you’ve installed 
the required software and hardware. You should have a working knowledge of 
your computer and operating system. You should know how to use the mouse 
and standard menus and commands, and also how to open, save, and close files. 
If you need to review these techniques, see the printed or online documentation 
included with your Microsoft® Windows® or Apple® macOS® software.

To complete the lessons in this book, you’ll need to have both Adobe After Effects 
CC (2019 release) and Adobe Bridge CC installed. �e exercises in this book are 
based on After Effects CC (2019 release).

Installing After Effects, Bridge, 
and Media Encoder
Adobe After Effects CC is not included with the book; you must purchase it sepa-
rately as part of an Adobe Creative Cloud subscription. For system requirements 
and complete instructions on installing the software, visit https://helpx.adobe.
com/after-effects/system-requirements.html. Note that After Effects CC requires  
a 64-bit operating system. To view QuickTime movies on macOS, you must also 
have Apple QuickTime 7.6.6 or later installed on your system.

Some of the lessons in this book use Adobe Bridge or Adobe Media Encoder. After 
Effects, Bridge, and Media Encoder use separate installers. You must install these 
applications from Adobe Creative Cloud (adobe.com) onto your hard disk. Follow 
the onscreen instructions.

Activating fonts
Several lessons use specific fonts that may not be installed on your system. You 
can activate the fonts using Adobe Fonts or choose a different font on your system 
with similar characteristics. If you choose a different font, your projects won’t look 
exactly like the ones shown in the book.

Adobe Fonts licenses are included in Creative Cloud subscriptions.

To activate fonts within After Effects, choose File > Fonts From Adobe, or click the 
Creative Cloud icon next to Add Adobe Fonts in the Font menu in the Character 
panel. �en, find the font in Adobe Fonts in your browser, and activate the font.

https://helpx.adobe.com/after-effects/system-requirements.html
https://helpx.adobe.com/after-effects/system-requirements.html
http://adobe.com


ADOBE AFTER EFFECTS CC CLASSROOM IN A BOOK (2019 RELEASE) 3

Optimizing performance
Creating movies is memory-intensive work for a desktop computer. After Effects CC 
(2019 release) requires a minimum of 8GB of RAM. �e more RAM that is available 
to After Effects, the faster the application will work for you. For information about 
optimizing memory, cache, and other settings for After Effects, see “Improve per-
formance” in After Effects Help.

Restoring default preferences
�e preferences files control the way the After Effects user interface appears on 
your screen. �e instructions in this book assume that you see the default interface 
when they describe the appearance of tools, options, windows, panels, and so forth. 
�erefore, it’s a good idea to restore the default preferences, especially if you are 
new to After Effects.

Each time you quit After Effects, the panel positions and certain command settings 
are recorded in the preferences files. To restore the original default settings, press 
Ctrl+Alt+Shift (Windows) or Command+Option+Shift (macOS) while starting 
After Effects. (After Effects creates new preferences files if they don’t already exist 
the next time you start the program.)

Restoring the default preferences can be especially helpful if someone has already 
customized After Effects on your computer. If your copy of After Effects hasn’t 
been used yet, these files won’t exist, so this procedure is unnecessary.

Important: If you want to save the current settings, you can rename a preferences 
file instead of deleting it. When you are ready to restore those settings, change the 
name back, and make sure that the file is located in the correct preferences folder.

1 Locate the After Effects preferences folder on your computer:

• For Windows: .../Users/<user name>/AppData/Roaming/Adobe/
AfterEffects/16.0

• For macOS: .../Users/<user name>/Library/Preferences/Adobe/
After Effects/16.0 

2 Rename any preferences files you want to preserve, and then restart After Effects.

� Note: In macOS, 
the user library folder 
is hidden by default. 
To see it, in the Finder, 
choose Go > Go To 
Folder. In the Go To 
Folder dialog box, type 
~/Library, and then 
click Go.
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Online content
Your purchase of this Classroom in a Book includes online materials provided by way 
of your Account page on peachpit.com. �ese include:

Lesson files
To work through the projects in this book, you will need to download the lesson 
files from peachpit.com. You can download the files for individual lessons or it may 
be possible to download them all in a single file. 

Web Edition
�e Web Edition is an online interactive version of the book providing an enhanced 
learning experience. Your Web Edition can be accessed from any device with a con-
nection to the Internet and it contains: 

• �e complete text of the book

• Hours of instructional video keyed to the text

• Interactive quizzes

Accessing the lesson files and Web Edition
If you purchased an eBook from peachpit.com or adobepress.com, your Web 
Edition will automatically appear under the Digital Purchases tab on your Account 
page. Click the Launch link to access the product. Continue reading to learn how  
to register your product to get access to the lesson files.

If you purchased an eBook from a different vendor or you bought a print  
book, you must register your purchase on peachpit.com in order to access the 
online content:

1 Go to www.peachpit.com/register.

2 Sign in or create a new account.

3 Enter the ISBN: 9780135298640.

4 Answer the questions as proof of purchase.

5 �e Web Edition will appear under the Digital Purchases tab on your Account 
page. Click the Launch link to access the product.

�e Lesson Files can be accessed through the Registered Products tab on your 
Account page. Click the Access Bonus Content link below the title of your 
product to proceed to the download page. Click the lesson file links to download 
them to your computer.

http://peachpit.com
http://peachpit.com
http://peachpit.com
http://adobepress.com
http://peachpit.com
http://www.peachpit.com/register
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Organizing the lesson files
�e files are compressed into ZIP archives to speed download time and protect 
the contents from damage during transfer. You must uncompress (or “unzip”) the 
files to restore them to their original size and format before you use them with the 
book. Modern Mac and Windows systems are set up to open ZIP archives by simply 
double-clicking.

1 On your hard drive, create a new folder in a convenient location, and name it 
Lessons, following the standard procedure for your operating system:

• In Windows, right-click, and choose New > Folder. �en enter the new name 
for your folder.

• In macOS, in the Finder, choose File > New Folder. Type the new name,  
and drag the folder to the location you want to use.

2 Drag the unzipped Lessons folder (which contains folders named Lesson01, 
Lesson02, and so on) that you downloaded onto your hard drive to your new 
Lessons folder. When you begin each lesson, navigate to the folder with that 
lesson number to access all the assets you need to complete the lesson.

About copying the sample movies and projects
You will create and render one or more movies in some lessons in this book.  
�e files in the Sample_Movies folders are examples that you can use to see the  
end results of each lesson and to compare them with your own results. 

�e files in the End_Project_File folders are samples of the completed project for each 
lesson. Use these files for reference if you want to compare your work in progress with 
the project files used to generate the sample movies. 

�ese sample movies and end-project files vary in size from relatively small to sev-
eral megabytes, so you can either download them all now if you have ample storage 
space, or download just the files for each lesson as needed, and then delete them 
when you finish that lesson.

How to use these lessons
Each lesson in this book provides step-by-step instructions for creating one or more 
specific elements of a real-world project. �e lessons build on each other in terms 
of concepts and skills, so the best way to learn from this book is to proceed through 
the lessons in sequential order. In this book, some techniques and processes are 
explained and described in detail only the first few times you perform them. 

� Note: If for any 
reason you need to 
download fresh copies 
of the lesson �les, you 
can download them 
from your account 
again at any time.
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Many aspects of the After Effects application can be controlled by multiple tech-
niques, such as a menu command, a button, dragging, and a keyboard shortcut. 
Only one or two of the methods are described in any given procedure, so that you 
can learn different ways of working even when the task is one you’ve done before.

�e organization of the lessons is also design-oriented rather than feature-oriented. 
�at means, for example, that you’ll work with layers and effects on real-world 
design projects over several lessons, rather than in just one lesson.

Additional resources
Adobe After Effects CC Classroom in a Book (2019 Release) is not meant to replace 
documentation that comes with the program or to be a comprehensive reference for 
every feature. Only the commands and options used in the lessons are explained in 
this book. 

Tutorials within After Effects can help you get started: In After Effects, choose 
Help > Learn After Effects. �e Learn panel opens with a series of tutorials. 

For comprehensive information about program features and tutorials, refer to 
these resources:

• Adobe After Effects Learn & Support: helpx.adobe.com/support/after-
effects.html is where you can find and browse tutorials, help, and support on 
www.Adobe.com.

• After Effects tutorials: helpx.adobe.com/after-effects/tutorials.html lists 
online tutorials for beginner and experienced users. You can go there directly 
from After Effects by choosing Help > Tutorials.

• After Effects Forums: forums.adobe.com/community/aftereffects_general_
discussion lets you tap into peer-to-peer discussions, and questions as well as 
answers about After Effects.

http://helpx.adobe.com/support/after-e$$$ects.html
http://helpx.adobe.com/support/after-e$$$ects.html
http://www.Adobe.com
http://helpx.adobe.com/after-e$$$ects/tutorials.html
http://forums.adobe.com/community/aftere$$$ects_general_discussion
http://forums.adobe.com/community/aftere$$$ects_general_discussion
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• Adobe Create Magazine: create.adobe.com offers thoughtful articles 
on design and design issues, a gallery showcasing the work of top-notch 
designers, tutorials, and more.

• Resources for educators: www.adobe.com/education and edex.adobe.com 
offer a treasure trove of information for instructors who teach classes on 
Adobe software. Find solutions for education at all levels, including free 
curricula that use an integrated approach to teaching Adobe software and 
can be used to prepare for the Adobe Certified Associate exams.

Also check out these useful links:

• Adobe Add-ons: exchange.adobe.com/addons is a central resource for 
finding tools, services, extensions, code samples, and more to supplement 
and extend your Adobe products.

• Adobe After Effects CC product home page: www.adobe.com/products/
aftereffects

Adobe Authorized Training Centers
Adobe Authorized Training Centers offer instructor-led courses and training  
on Adobe products. A directory of AATCs is available at https://training.adobe.
com/training/partner-finder.html

http://create.adobe.com
http://www.adobe.com/education
http://edex.adobe.com
http://exchange.adobe.com/addons
http://www.adobe.com/products/aftereffects
http://www.adobe.com/products/aftereffects
https://training.adobe.com/training/partner-�nder.html
https://training.adobe.com/training/partner-�nder.html


8

GETTING TO KNOW 
THE WORKFLOW

Lesson overview
In this lesson, you’ll learn how to do the following:

• Create a project and import footage.

• Create compositions and arrange layers.

• Navigate the Adobe After Effects interface.

• Use the Project, Composition, and Timeline panels.

• Transform layer properties.

• Apply basic effects.

• Create keyframes.

• Preview your work.

• Customize the workspace.

• Adjust preferences related to the user interface.

• Find additional resources for using After Effects.

�is lesson will take about an hour to complete. Download the project 
files for this lesson, following the instructions in the Getting Started 
section under “Accessing the lesson files and Web Edition,” if you 
haven’t already done so. As you work on this lesson, you’ll preserve the 
start files. If you need to restore the start files, download them from your 
Account page. 

1



9

Whether you use After E�ects to animate a simple 
DVD title sequence or to create complex special 
e�ects, you generally follow the same basic work�ow. 
The After E�ects interface facilitates your work and 
adapts to each stage of production. 

PROJECT:  TITLE SEQUENCEPROJECT:  TITLE SEQUENCE
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About the After Effects work area
After E�ects o�ers a �exible, customizable work area. The main window of the program is called  
the application window. Panels are organized in this window in an arrangement called a workspace.  
The default workspace contains stacked panels as well as panels that stand alone, as shown below. 

A CB D

E
F

G

A.  Application window B. Composition panel C. Workspace bar D. Stacked panels E. Tools panel F. Project panel 
G. Timeline panel

You customize a workspace by dragging the panels into the con�guration that best suits your working  
style. You can drag panels to new locations, change the order of stacked panels, move panels into or out  
of a group, place panels alongside each other, stack panels, and undock a panel so that it �oats in a new 
window above the application window. As you rearrange panels, the other panels resize automatically to �t  
the window. 

When you drag a panel by its tab to relocate it, the area where you can drop it—called a drop zone—
becomes highlighted. The drop zone determines where and how the panel is inserted into the workspace. 
Dragging a panel to a drop zone either docks it, groups it, or stacks it.

If you drop a panel along the edge of another panel, group, or window, it will dock next to the existing 
group, resizing all groups to accommodate the new panel.

If you drop a panel in the middle of another panel or group, or along the tab area of a panel, it will be added 
to the existing group and be placed at the top of the stack. Grouping a panel does not resize other groups. 

You can also open a panel in a �oating window. To do so, select the panel, and then choose Undock Panel  
or Undock Frame from the panel menu. Or, drag the panel or group outside the application window.
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Getting started
A basic After Effects workflow follows six steps: importing and organizing footage, 
creating compositions and arranging layers, adding effects, animating elements, 
previewing your work, and rendering and outputting the final composition so  
that it can be viewed by others. In this lesson, you will create a simple animated 
video using this workflow, and along the way, you’ll learn your way around the 
After Effects interface. 

First, you’ll preview the final movie to see what you’ll create in this lesson.

1 Make sure the following files are in the Lessons/Lesson01 folder on your hard 
disk, or download them from your Account page at www.peachpit.com now:

• In the Assets folder: movement.mp3, swimming_dog.mp4, title.psd

• In the Sample_Movies folder: Lesson01.avi, Lesson01.mov

2 Open and play the Lesson01.avi sample movie in Windows Movies & TV or the 
Lesson01.mov sample movie in QuickTime Player to see what you will create 
in this lesson. When you are done, close Windows Movies & TV or QuickTime 
Player. You may delete the sample movies from your hard disk if you have limited 
storage space. 

Creating a project and importing footage
When you begin each lesson of this book, it’s a good idea to restore the default pref-
erences for After Effects. (For more information, see “Restoring default preferences” 
on page 3.) You can do this with a simple keyboard shortcut.

1 Start After Effects, and then immediately hold down Ctrl+Alt+Shift (Windows) 
or Command+Option+Shift (macOS) to restore default preferences settings. 
When prompted, click OK to delete your preferences.

�e Home window opens. It provides easy access to your recent After Effects  
projects, as well as to tutorials and more information about After Effects.

2 Click New Project in the Home window. 

� Tip: Restoring 
default preferences  
can be tricky in 
Windows, especially if 
you’re working on a fast 
system. Press the keys 
after you double-click 
the application icon 
but before After E�ects 
begins to list the �les  
it’s activating. Alterna-
tively, you can choose 
Edit > [your Creative 
Cloud account 
username] > Clear 
Settings, and then 
restart the application.

http://www.peachpit.com
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After Effects displays an empty, untitled project.

An After Effects project is a single file that stores references to all the footage  
you use in that project. It also contains compositions, which are the individual  
containers used to combine footage, apply effects, and, ultimately, drive the output.

When you begin a project, often the first thing you’ll do is add footage to it.

3 Choose File > Import > File.

4 Navigate to the Assets folder in your Lessons/Lesson01 folder. Shift-click to select 
the movement.mp3 and swimming_dog.mp4 files. �en click Import or Open.

� Tip: To quickly 
maximize a panel, 
double-click the panel 
tab. To return it to its 
original size, double-
click the tab again.
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A footage item is the basic unit in an After Effects project. You can import many  
types of footage items, including moving-image files, still-image files, still-image 
sequences, audio files, layered files from Adobe Photoshop and Adobe Illustrator,  
other After Effects projects, and projects created in Adobe Premiere® Pro. You can 
import footage items at any time.

As you import assets, After Effects reports its progress in the Info panel. 

Because one of the footage items for 
this project is a multilayer Photoshop 
file, you’ll import it separately as a 
composition.

5 Double-click in the lower area 
of the Project panel to open the 
Import File dialog box. 

6 Navigate to the Lesson01/Assets folder again, and select the title.psd file. Choose 
Composition from the Import As menu. (In macOS, you may need to click 
Options to see the Import As menu.) �en click Import or Open. 

After Effects opens an additional dialog box that displays options for the file you  
are importing.

� Tip: You can also 
choose File > Import > 
Multiple Files to select 
�les located in di�erent 
folders or drag and drop 
�les from Explorer or 
the Finder. You can use 
Adobe Bridge to search 
for, manage, preview, 
and import footage. 
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7 In the title.psd dialog box, choose  
Composition from the Import Kind  
menu to import the layered Photoshop 
file as a composition. Select Editable  
Layer Styles in the Layer Options area,  
and then click OK. 

�e footage items appear in the Project 
panel.

8 In the Project panel, click to select different footage items. Notice that a thumb-
nail preview appears at the top of the Project panel. You can also see the file type 
and size, as well as other information about each item, in the Project panel columns.

When you import files, After Effects doesn’t copy the video and audio data itself  
into your project. Instead, each footage item in the Project panel contains a refer-
ence link to the source files. When After Effects needs to retrieve image or audio 
data, it reads it from the source file. �is keeps the project file small and allows  
you to update source files in another application without modifying the project.

If you move a file or if After Effects can’t access its location, it will report that the 
file is missing. To identify missing files, choose File > Dependencies > Find Missing 
Footage. You can also type Missing Footage into the Search box in the Project 
panel to look for the missing assets.

To save time and minimize the size and complexity of a project, you’ll usually import 
a footage item once even if you’re using it multiple times in a composition. However, 
you may sometimes need to import a source file more than once, such as if you want 
to use it at two different frame rates.

� Tip: You can locate 
missing fonts or e�ects 
the same way. Choose 
File > Dependencies, 
and then choose Find 
Missing Fonts or Find 
Missing E�ects. Or just 
type Missing Fonts or 
Missing E�ects into 
the Search box in the 
Project panel.



ADOBE AFTER EFFECTS CC CLASSROOM IN A BOOK (2019 RELEASE) 15

After you’ve imported footage, it’s a good time to save the project.

9 Choose File > Save. In the Save As dialog box, navigate to the Lessons/
Lesson01/Finished_Project folder. Name the project Lesson01_Finished.aep, 
and then click Save.

Creating a composition and arranging layers
�e next step of the workflow is to create a composition. You create all animation, 
layering, and effects in a composition. An After Effects composition has both spatial 
dimensions and a temporal dimension (time).

Compositions include one or more layers, arranged in the Composition panel 
and in the Timeline panel. Any item that you add to a composition—such as a 
still image, moving-image file, audio file, light layer, camera layer, or even another 
composition—becomes a new layer. Simple projects may include only one composi-
tion, while elaborate projects may include several compositions to organize large 
amounts of footage or intricate effects sequences.

To create a composition, you’ll drag the footage items into the Timeline panel,  
and After Effects will create layers for them.

1 In the Project panel, Shift-click 
to select the movement.mp3, 
swimming_dog.mp4, and title 
assets. Don’t select the title Layers 
folder.

2 Drag the selected footage items 
into the Timeline panel. �e New 
Composition From Selection dialog 
box appears.

� Tip: To create  
a composition from 
footage as you import 
it, select Create 
Composition in the 
Import File dialog box.
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After Effects bases the dimensions of the new composition on the selected footage. 
In this example, all of the footage is sized identically, so you’ll accept the default 
settings for the composition.

3 Select swimming_dog.mp4 in the Use Dimensions From menu, and then click 
OK to create the new composition. 

�e footage items appear as layers in the Timeline panel, and After Effects displays 
the composition, named swimming_dog, in the Composition panel. 

When you add a footage item to a composition, that footage becomes the source for 
a new layer. A composition can have any number of layers, and you can also include 
a composition as a layer in another composition, which is called nesting.

Some of the assets are longer than others, but you want them all to continue only  
as long as the swimming dog is on the screen. You’ll change the length of the entire  
composition to 7:00 to match the dog clip.

4 Choose Composition > Composition Settings.
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5 In the Composition Settings dialog box, rename the composition movement, 
type 7:00 for the Duration, and then click OK.

�e Timeline panel displays the same duration for each of the layers.

In this composition, there are three footage items, and therefore three layers in 
the Timeline panel. Depending on the order in which the elements were selected 
when you imported them, your layer stack may differ from the one shown on the 
previous page. �e layers need to be in a specific order as you add effects and 
animations, however, so you’ll rearrange them now.

About layers
Layers are the components you use to build a composition. Any item that you  
add to a composition—such as a still image, moving-image �le, audio �le, light 
layer, camera layer, or even another composition—becomes a new layer. Without 
layers, a composition consists only of an empty frame.

Using layers, you can work with speci�c footage items in a composition without 
a�ecting any other footage. For example, you can move, rotate, and draw masks  
for one layer without disturbing any other layers in the composition, or you can  
use the same footage in more than one layer and use it di�erently in each instance. 
In general, the layer order in the Timeline panel corresponds to the stacking order in 
the Composition panel.



18 LESSON 1 Getting to Know the Workflow

6 Click an empty area of the Timeline panel to deselect the layers, and then drag 
the title layer to the top of the layer stack, if it is not already there. Drag the 
movement.mp3 layer to the bottom of the layer stack.

7 Choose File > Save to save your project so far.

Adding effects and modifying 
layer properties
Now that your composition is set up, you can start having fun—applying effects, 
making transformations, and adding animation. You can add any combination of 
effects and modify any of a layer’s properties, such as size, placement, or opacity. 
Using effects, you can alter a layer’s appearance or sound, and even generate visual 
elements from scratch. �e easiest way to start is to apply any of the hundreds of 
effects included with After Effects. 

Transforming layer properties
�e title is currently in the center of the screen, obscuring the dog and distracting 
from the action. You’ll move it to the lower left corner, where it will remain visible 
but not in the way.

1 Select the title layer (layer 1) in the Timeline panel. Notice that layer handles 
appear around the layer in the Composition panel.

� Tip: To deselect all 
layers, click a blank area 
of the Timeline panel or 
press F2.

� Note: This exercise 
is just the tip of the 
iceberg. You will learn 
more about e�ects and 
animation presets in 
Lesson 2, “Creating a 
Basic Animation Using 
E�ects and Presets,” and 
throughout the rest of 
this book.
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2 Click the triangle to the left of the layer number to expand the layer, and 
then expand the layer’s Transform properties: Anchor Point, Position, Scale, 
Rotation, and Opacity. 

3 If you can’t see the properties, scroll down the Timeline panel using the scroll 
bar at the right side of the panel. Better yet, select the title layer name again,  
and press P. 

Expand Transform to see all its properties. Press P to see just the Position property.

�is keyboard shortcut displays only the Position property, which is the only property 
you want to change for this exercise. You’ll move this layer to the lower left corner.

4 Change the coordinates for the Position property to 265, 635. Or use the 
Selection tool to drag the title to the lower left corner of the screen.

5 Press P to hide the Position property, or click the triangle to the left of the layer 
number to hide all properties.

Adding an effect to correct color
After Effects includes several effects to correct or modify color in your projects. 
You’ll use the Auto Contrast effect to adjust the overall contrast in the clip and 
intensify the color of the water.
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1 Select the swimming_dog.mp4 layer in the Timeline panel. 

2 Click the Effects & Presets panel (in the panel stack at the right side of the appli-
cation window) to open it, and type contrast in the search box.

After Effects searches for effects and presets that contain the letters you type, and 
displays the results interactively. Before you have finished typing, the Auto Contrast 
effect—located in the Color Correction category—appears in the panel.

3 Drag the Auto Contrast effect onto the swimming_dog layer in the  
Timeline panel. 

After Effects applies the effect and automatically opens the Effect Controls panel  
in the upper left area of the workspace.

� Note: If you 
double-click a layer  
in the Timeline panel, 
After E�ects opens 
the layer in the Layer 
panel. To return to the 
Composition panel, click 
the Composition tab.
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�e contrast intensifies colors a little more than we need. You’ll customize the settings 
to reduce the effect.

4 In the Effect Controls panel, click the number next to Blend With Original,  
type 20%, and press Enter or Return to accept the new value.

Adding a stylistic effect
After Effects also includes many stylistic effects. You’ll add a beam of light to the clip 
to add an artistic touch. You’ll change the settings of this effect to modify the angle 
and intensity of the light. 

1 Click the x in the search box in the Effects & Presets panel to clear it, and then 
locate the CC Light Sweep effect by doing one of the following:

• Type CC Light in the search box.

• Click the triangle next to Generate to expand the category in alphabetical order.

2 Drag the CC Light Sweep effect in the Generate category onto the swimming_
dog layer name in the Timeline panel. After Effects adds the CC Light Sweep 
settings to the Effect Controls panel under the Auto Contrast effect.
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3 In the Effect Controls panel, click the triangle next to the Auto Contrast effect  
to hide those settings so that you can see the CC Light Sweep settings more easily.

First, you’ll change the angle of the light.

4 For Direction, type 37°. 

5 From the Shape menu, choose Smooth to widen and soften the light beam.

6 For Width, type 68 to widen the beam a bit more. 

7 Change the Sweep Intensity value to 20 to make the beam a little more subtle.

8 Choose File > Save to save your work so far.

Animating the composition
So far, you’ve started a project, created a composition, imported footage, and 
applied some effects. It all looks great, but how about some movement? You’ve 
applied only static effects.

In After Effects, you can change any combination of a layer’s properties over time 
using conventional keyframing, expressions, or keyframe assistants. You’ll explore 
many of these methods throughout the lessons of this book. For this project, you’ll 
apply an animation preset to introduce the title to the screen, and you’ll animate 
the title’s color over time. 
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Preparing the text composition
In this exercise, you’ll work with a separate composition—the one you imported 
from a layered Photoshop file.

1 Select the Project tab to display the Project panel, and then double-click the title 
composition to open it as a composition in its own Timeline panel.

�is composition is the layered Photoshop file you imported. Two layers—Title Here 
and Ellipse 1—appear in the Timeline panel. �e Title Here layer contains place-
holder text that was created in Photoshop. 

At the top of the Composition panel is the Composition Navigator bar, which dis-
plays the relationship between the main composition (movement) and the current 
composition (title), which is nested within the main composition. 

You can nest multiple compositions within each other; the Composition Navigator 
bar displays the entire composition path. Arrows between the composition names 
indicate the direction in which information flows.

Before you can replace the text, you need to make the layer editable. 

� Note: If the Project 
tab isn’t visible, choose 
Window > Project to 
open the Project panel.
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2 Select the Title Here layer (layer 1) in the Timeline panel, and then choose Layer > 
Create > Convert To Editable Text.

A T icon appears next to the layer name in the Timeline panel, indicating that it 
is now an editable text layer. �e layer is also selected in the Composition panel, 
ready for you to edit.

�e blue lines at the top, bottom, and sides of the Composition panel indicate  
title-safe and action-safe zones. Television sets enlarge a video image and allow 
some portion of its outer edges to be cut off by the edge of the screen. �is is 
known as overscan. �e amount of overscan is not consistent between television 
sets, so you should keep important parts of a video image, such as action or titles, 
within margins called safe zones. Keep your text inside the inner blue guides to 
ensure that it is in the title-safe zone, and keep important scene elements inside  
the outer blue guides to ensure that they are in the action-safe zone.

Editing text
You’ll start by replacing the placeholder text with real text. �en you’ll format  
it to fit the space better.

1 Select the Horizontal Type tool ( ) in the Tools panel, and drag over the 
placeholder text in the Composition panel to select it. �en type on the move. 

� Note: If you see 
a warning about 
missing fonts or layer 
dependencies, click  
OK. If Adobe Fonts 
opens, activate the 
missing font.

� Note: After E�ects 
o�ers robust character 
and paragraph 
formatting controls, 
but the default 
settings—whatever 
typeface appears when 
you type—should be 
�ne for this project. 
You’ll learn more 
about type in Lesson 3, 
“Animating Text.”
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About the Tools panel
As soon as you create a composition, the tools in the Tools panel in the upper 
left corner of the After E�ects application window become available. After E�ects 
includes tools that enable you to modify elements of your composition. Some of 
these tools—the Selection tool and the Hand tool, for example—will be familiar  
to you if you use other Adobe applications, such as Photoshop. Others will be new. 

A B C D E F G H I J K L M N O

 A. Home B. Selection C. Hand D. Zoom E. Rotation F. Camera tools G. Pan Behind  
H. Mask and Shape tools I. Pen tools J. Type tools K. Brush L. Clone Stamp M. Eraser  
N. Roto Brush and Re�ne Edge tools O. Puppet tools

When you hover the pointer over any button in the Tools panel, a tool tip identi�es 
the tool and its keyboard shortcut. A small triangle in the lower right corner of the 
button indicates that one or more additional tools are hidden behind it. Click and 
hold the button to display the hidden tools, and then select the tool you want to use.

2 Select the text again. �en, in the Character panel (docked on the right side 
of the screen), change the text size to 100 px and the tracking to –50.

Animating text with animation presets
Now that the text is formatted, you can apply an animation preset. You’ll use the  
Fade Up Words preset, so the words will appear in order over time.

1 Select the Title Here layer in the Timeline panel again, and make sure you’re  
at the first frame of the animation by doing one of the following:

• Drag the current-time indicator all the way to the left of the time ruler, to 0:00.

• Press the Home key on your keyboard. 
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2 Select the Effects & Presets tab to display the Effects & Presets panel. �en type 
fade up words in the search box. 

3 Select the Fade Up Words effect in the Animate In category, and drag it onto  
the on the move text in the Composition panel. 

After Effects adds the effect. Because it’s a simple effect, there are no settings  
in the Effect Controls panel.

4 Manually preview the effect by dragging the current-time indicator from  
0:00 to 1:00. �e words fade in, so that they are all onscreen by 1:00. 

About timecode and duration
The primary concept related to time is duration, or length. Each footage item,  
layer, and composition in a project has its own duration, which is re�ected in the 
beginning and ending times displayed in the time rulers in the Composition, Layer, 
and Timeline panels.

The way you view and specify time in After E�ects depends on the display style, 
or unit of measure, that you use to describe time. By default, After E�ects displays 
time in Society of Motion Picture and Television Engineers (SMPTE) timecode: 
hours, minutes, seconds, and frames. Note that the �gures are separated by 
semicolons in the After E�ects interface, representing drop-frame timecode 
(which adjusts for the real-time frame rate), but this book uses a colon to represent 
non-drop-frame timecode.

To learn when and how to change to another system of time display, such as frames, 
or feet and frames of �lm, see After E�ects Help.

� Tip: If you don’t see 
the E�ects & Presets 
tab, choose Window > 
E�ects & Presets.
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About the Timeline panel
Use the Timeline panel to animate layer properties and set In and Out points for a layer. (In and  
Out points are the points at which a layer begins and ends in the composition.) Many of the Timeline 
panel controls are organized in columns of related functions. By default, the Timeline panel contains  
a number of columns and controls, as shown here:

A B C

D E F G

A. Current time B. Composition name C. Timeline panel menu D. Audio/Video Switches column 
E. Source Name/Layer Name column F. Layer switches G. Time graph/Graph Editor area  

Understanding the time graph
The time graph portion of the Timeline panel (the right side) contains a time ruler, markers to indicate 
speci�c times, and duration bars for the layers in your composition.

A

B

C

E
D

F

Before delving too deeply into animation, it will help to understand at least some of these controls.  
The duration of a composition, a layer, or a footage item is represented visually in the time graph. On the 
time ruler, the current-time indicator marks the frame you are viewing or editing, and the frame appears 
in the Composition panel.

The work area start and end brackets indicate the part of the composition that will be rendered for 
previews or �nal output. When you work on a composition, you may want to render only a portion  
of it by specifying a segment of the composition time ruler as a work area.

A composition’s current time appears in the upper left corner of the Timeline panel. To move to a di�erent 
time, drag the current-time indicator in the time ruler—or click the current-time �eld in the Timeline 
panel or Composition panel, type a new time, and press Enter or Return, or click OK.

For more information about the Timeline panel, see After E�ects Help.

A. Time navigator start and end brackets  
B. Work area start and end brackets  
C. Time zoom slider  
D. Time ruler  
E. Composition marker bin  
F. Composition button
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Animating effects using keyframes
You’ll add an effect to the type layer, but this time, you’ll animate its settings using 
keyframes.

1 Go to the beginning of the time ruler by doing one of the following:

• Drag the current-time indicator to the left in the time ruler so that  
it’s positioned at 0:00.

• Click the Current Time field in the Timeline panel or Composition panel, 
and type 00. If you clicked in the Current Time field in the Composition 
panel, click OK to close the Go To Time dialog box.

2 Type channel blur in the search box in the Effects & Presets panel. 

3 Drag the Channel Blur effect onto the Title Here layer in the Timeline panel. 

After Effects adds the Channel Blur effect to the layer and displays its settings in the 
Effect Controls panel. �e Channel Blur effect individually blurs the red, green, blue, 
and alpha channels in a layer. It will create an interesting look for the title. 

4 In the Effect Controls panel, set the Red Blurriness, Green Blurriness, Blue 
Blurriness, and Alpha Blurriness values to 50.

5 Click the stopwatch icon ( ) next to each of the settings you changed to create 
initial keyframes. �e text will be blurred as it first appears.

Keyframes are used to create and control animation, effects, audio properties,  
and many other kinds of changes that occur over time. A keyframe marks the 
point in time where you specify a value, such as spatial position, opacity, or audio 
volume. Values between keyframes are interpolated. When you use keyframes to 
create a change over time, you must use at least two keyframes—one for the state  
at the beginning of the change, and one for the state at the end of the change.

6 From the Blur Dimensions menu, choose Vertical. 
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7 Go to 1:00 in the timeline.

8 Change the values to the following:

• Red Blurriness: 0

• Green Blurriness: 0

• Blue Blurriness: 0

• Alpha Blurriness: 0

9 Manually preview the effect by moving the current-time indicator from 0 to 1:00.

Changing the opacity of the background
�e title looks good, but the ellipse is too bright. You’ll change its opacity so that 
the water in the video shows through. 

1 In the Timeline panel, select the Ellipse 1 layer.

2 Press T to reveal the layer’s Opacity property. 

3 Change the Opacity value to 20%.

� Tip: To remember 
the keyboard shortcut 
for the Opacity 
property, think of it as 
transparency.

� Tip: To see how 
the title appears over 
the water, click the 
movement tab in the 
Timeline panel.
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Previewing your work
You’re probably eager to see the results of your work. You can preview your compo-
sition using the Preview panel, which is in the stacked panels on the right side of the 
application window in the default workspace. To preview your composition, click 
the Play/Stop button in the Preview panel, or press the spacebar on your keyboard.

1 In the title Timeline panel, hide all layer properties, and deselect all layers.

2 Make sure that the Video switch ( ) is selected for the layers that you want  
to preview—in this case, the Title Here and Ellipse 1 layers.

3 Press the Home key to go to the beginning of the time ruler.

4 Do one of the following:

• Click the Play/Stop button ( ) in the Preview panel.
• Press the spacebar.

5 To stop the preview, do one of the following:

• Click the Play/Stop button in the Preview panel.

• Press the spacebar.

You’ve previewed a simple animation, so it probably played back in real time.

When you press the spacebar or click the Play/Stop button, After Effects caches  
the composition and allocates enough RAM to play the preview (with audio) as 
fast as the system allows, up to the frame rate of the composition. �e number 
of frames played depends on the amount of RAM available to the application. 
Often, the preview will play in real time only after After Effects has cached all the 
included frames.

In the Timeline panel, the preview plays either the span of time you specify as the 
work area, or from the beginning of the time ruler. In the Layer and Footage panels, 
the preview plays only untrimmed footage. Before you preview, check which frames 
are designated as the work area.

� Tip: Verify that the 
work area brackets 
include all the frames 
you want to preview. 
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Now you’ll preview the entire composition—the animated text plus graphic effects.

6 Click the movement tab in the Timeline panel to bring it forward.

7 Make sure that the Video switch ( ) is turned on for all of the layers in the 
composition except the audio layer, and press F2 to deselect all layers.

8 Drag the current-time indicator to the beginning of the time ruler, or press  
the Home key.

9 To start the preview, click the Play/Stop button ( ) in the Preview panel, or press 
the spacebar. 

A green progress bar indicates which frames are cached to RAM. When all of the 
frames in the work area are cached, the preview plays back in real time. Until all  
the frames are cached, the playback may be slower and the audio may drag. 


